GetLightFamily Method


Light Family Get Light Family Method

Creates a light family object from the given family document

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static LightFamily GetLightFamily(
	Document document
)

Parameters

document Document
The family document

Return Value

LightFamily
The newly created LightFamily object
Exceptions
Exception Condition
ArgumentException The Document is the argument that is being validated The document is not valid because it is not a light family document.
ArgumentNullException A non-optional argument was null
See Also