FabricationNetworkChangeService Class


This class represents the fabrication part change service and change size tools.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018.2

Syntax

C#
public class FabricationNetworkChangeService : IDisposable
Visual Basic
Public Class FabricationNetworkChangeService _
	Implements IDisposable
Visual C++
public ref class FabricationNetworkChangeService : IDisposable

Remarks

After a new instance of the class is created, call the ChangeService method to change the service of the fabrication parts or call the ChangeSize method to change the size of the fabrication parts. There is another workflow allowing for more control, call SetSelection to set the selection of fabrication parts to change. To change the service, call SetServiceId and SetPaletteId to set the service identifier and palette identifier. Changing the service there is an optional methods GetInLinePartTypes and SetMapOfSizesForStraights that can be called to replace in-line valves and dampers to the corresponding parts for the new service. The size can also be changed by calling GetMapOfAllSizesForStraights that will return a FabricationPartSizeMapSet containing a map of sizes for all straights found in the selection of fabrication parts. The FabricationPartSizeMapSet can then be modified to set the mapped values for the new size for the fabrication part straights and then call SetMapOfSizesForStraights set the new sizes that are to be applied. Finally call ApplyChange to apply the previously set parameters to the selection of fabrication parts.

Inheritance Hierarchy

System Object
Autodesk.Revit.DB.Fabrication FabricationNetworkChangeService

See Also