FabricationNetworkChangeService Class


Fabrication Network Change Service Class

This class represents the fabrication part change service and change size tools.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Fabrication FabricationNetworkChangeService

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricationNetworkChangeService : IDisposable

The FabricationNetworkChangeService type exposes the following members.

Constructors
Name Description
Public method FabricationNetworkChangeService Creates a new instance of the FabricationNetworkChangeService class.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method ApplyChange Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.
Public method ChangeService(ISet ElementId , Int32, Int32)
Public method ChangeService(ISet ElementId , Int32, Int32, Boolean)
Public method ChangeSize
Public method Dispose Releases all resources used by the FabricationNetworkChangeService
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetElementsThatFailed Gets the set of fabrication parts that had failures due to either there was no corresponding part in the service, the size was out of range, or a connection could not be made.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetInLinePartTypes Get a set of element identifiers of fabrication part types for in-line parts.
Public method GetMapOfAllSizesForStraights Get a set of FabricationPartSizeMapSet of all straight sizes for all services.
Public method GetStraightsThatWereNotChanged Gets the set of fabrication part straights that were not changed due to either there was no corresponding part in the service or the size was out of range.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetMapOfInLinePartTypes
Public method SetMapOfSizesForStraights
Public method SetPaletteId Set the fabrication palette identifier to change the elements to.
Public method SetRestrictPalette Restrict the placement of parts to only use parts associated to the passed in fabrication palette identifier.
Public method SetSelection
Public method SetServiceId Set the fabrication service identifier to change the elements to.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
After a new instance of the class is created, call the ChangeService method to change the service of the fabrication parts or call the ChangeSize method to change the size of the fabrication parts. There is another workflow allowing for more control, call SetSelection to set the selection of fabrication parts to change. To change the service, call SetServiceId and SetPaletteId to set the service identifier and palette identifier. Changing the service there is an optional methods GetInLinePartTypes and SetMapOfSizesForStraights that can be called to replace in-line valves and dampers to the corresponding parts for the new service. The size can also be changed by calling GetMapOfAllSizesForStraights that will return a FabricationPartSizeMapSet containing a map of sizes for all straights found in the selection of fabrication parts. The FabricationPartSizeMapSet can then be modified to set the mapped values for the new size for the fabrication part straights and then call SetMapOfSizesForStraights set the new sizes that are to be applied. Finally call ApplyChange to apply the previously set parameters to the selection of fabrication parts.
See Also