Converts a collection of pipe placeholder elements into pipe elements.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- placeholderIds
- Type: System.Collections.Generic ICollection ElementId
A collection of element IDs of pipe placeholders.
Return Value
A collection of element IDs of pipe and fitting.Remarks
Once conversion succeeds, the pipe placeholder elements are deleted. The new pipe and fitting elements are created and connections are established.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given element id set is empty. -or- The given element ids (placeholderIds) are not pipe placeholders. -or- The elements belong to different types of system. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |