ConvertPipePlaceholders Method


Converts a collection of pipe placeholder elements into pipe elements.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static ICollection<ElementId> ConvertPipePlaceholders(
	Document document,
	ICollection<ElementId> placeholderIds
)
Visual Basic
Public Shared Function ConvertPipePlaceholders ( _
	document As Document, _
	placeholderIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ConvertPipePlaceholders(
	Document^ document, 
	ICollection<ElementId^>^ placeholderIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
placeholderIds
Type: System.Collections.GenericICollectionElementId
A collection of element IDs of pipe placeholders.

Return Value

A collection of element IDs of pipe and fitting.

Remarks

Once conversion succeeds, the pipe placeholder elements are deleted. The new pipe and fitting elements are created and connections are established.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element id set is empty. -or- The given element ids (placeholderIds) are not pipe placeholders. -or- The elements belong to different types of system.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also