IsValidParameterDefinitionId Method


Checks whether the input parameter id can be applied to the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public bool IsValidParameterDefinitionId(
	ElementId parameterId
)
Visual Basic
Public Function IsValidParameterDefinitionId ( _
	parameterId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidParameterDefinitionId(
	ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB ElementId

Return Value

Returns true if the input parameter id can be set to this scheme, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also