Returns all alignment station labels placed on the given alignment in the given view.
Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- alignment
- Type: Autodesk.Revit.DB.Infrastructure Alignment
The alignment for which the labels are returned.
- viewId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the view for which the labels are returned.
Remarks
The resulting collection may contain both "individual" labels (created via Create(Alignment, View, AlignmentStationLabelOptions) ) and "labels in set" (created via CreateSet(Alignment, View, AlignmentStationLabelSetOptions) ). These labels have categories respectively OST_Alignments and OST_AlignmentStationLabelSets .