GetAlignmentStationLabels Method (Alignment, ElementId)


Alignment Station Label Get Alignment Station Labels(Alignment, Element Id) Method

Returns all alignment station labels placed on the given alignment in the given view.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<AlignmentStationLabel> GetAlignmentStationLabels(
	Alignment alignment,
	ElementId viewId
)

Parameters

alignment Alignment
The alignment for which the labels are returned.
viewId ElementId
The ElementId of the view for which the labels are returned.

Return Value

ICollection AlignmentStationLabel
Remarks
The resulting collection may contain both "individual" labels (created via Create(Alignment, View, AlignmentStationLabelOptions) ) and "labels in set" (created via CreateSet(Alignment, View, AlignmentStationLabelSetOptions) ). These labels have categories respectively OST_Alignments and OST_AlignmentStationLabelSets .
See Also