Erase the existing ConduitSize with this nominal diameter. The conduit standard name determines the location of the size in the size table.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- standardName
- Type: System String
The conduit standard name.
- nominalDiameter
- Type: System Double
Nominal diameter.
Remarks
Does nothing if there is no existing ConduitSize with this nominal diameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. |
Autodesk.Revit.Exceptions InvalidOperationException | The function is called during iterating the size set. |