Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- subContextName
- Type: System String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.
Return Value
The IfcRepresentationContext for 3D entities.Remarks
The context handle automatically incorporates the angle to true north for the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |