Get3DContextHandle Method


Exporter IFC Get 3DContext Handle Method

Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCAnyHandle Get3DContextHandle(
	string subContextName
)

Parameters

subContextName String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.

Return Value

IFCAnyHandle
The IfcRepresentationContext for 3D entities.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The context handle automatically incorporates the angle to true north for the document.
See Also