Submits geometry for rendering.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexBuffer
- Type: Autodesk.Revit.DB.DirectContext3D VertexBuffer
The vertex buffer that contains vertex data.
- vertexCount
- Type: System Int32
The number of vertices in the vertex buffer.
- indexBuffer
- Type: Autodesk.Revit.DB.DirectContext3D IndexBuffer
The index buffer that contains indices into the vertex buffer.
- indexCount
- Type: System Int32
The number of indices in the index buffer.
- vertexFormat
- Type: Autodesk.Revit.DB.DirectContext3D VertexFormat
The format of the vertices in the vertex buffer.
- effectInstance
- Type: Autodesk.Revit.DB.DirectContext3D EffectInstance
The effect instance to be used for drawing this piece of geometry.
- primitiveType
- Type: Autodesk.Revit.DB.DirectContext3D PrimitiveType
The type of geometry primitive used in the index buffer.
- start
- Type: System Int32
The first index to use for drawing.
- primitiveCount
- Type: System Int32
The number of primitives to draw.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | A change in the graphics state has made the vertex buffer vertexBuffer invalid for rendering. -or- A change in the graphics state has made the index buffer indexBuffer invalid for rendering. -or- A change in the graphics state has made the vertex format vertexFormat invalid for rendering. -or- A change in the graphics state has made the effect instance effectInstance invalid for rendering. -or- The vertex format vertexFormat and the effect instance effectInstance do not match. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |