FlushBuffer Method


Draw Context Flush Buffer Method

Submits geometry for rendering.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static void FlushBuffer(
	VertexBuffer vertexBuffer,
	int vertexCount,
	IndexBuffer indexBuffer,
	int indexCount,
	VertexFormat vertexFormat,
	EffectInstance effectInstance,
	PrimitiveType primitiveType,
	int start,
	int primitiveCount
)

Parameters

vertexBuffer VertexBuffer
The vertex buffer that contains vertex data.
vertexCount Int32
The number of vertices in the vertex buffer.
indexBuffer IndexBuffer
The index buffer that contains indices into the vertex buffer.
indexCount Int32
The number of indices in the index buffer.
vertexFormat VertexFormat
The format of the vertices in the vertex buffer.
effectInstance EffectInstance
The effect instance to be used for drawing this piece of geometry.
primitiveType PrimitiveType
The type of geometry primitive used in the index buffer.
start Int32
The first index to use for drawing.
primitiveCount Int32
The number of primitives to draw.
Exceptions
Exception Condition
ArgumentException A change in the graphics state has made the vertex buffer vertexBuffer invalid for rendering. -or- A change in the graphics state has made the indexBuffer invalid for rendering, or indexBuffer is null and indexCount is not zero. -or- A change in the graphics state has made the vertex format vertexFormat invalid for rendering. -or- A change in the graphics state has made the effect instance effectInstance invalid for rendering. -or- The vertex format vertexFormat and the effect instance effectInstance do not match.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also