Adds a filter to the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterElementId
- Type: Autodesk.Revit.DB ElementId
ElementId of the filter.
Remarks
The filter will be added with default overrides, which means that there will be no change in the view's display. The filter is appended as the last filter in the order of filters applied to this view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is already applied to the view. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |