View Add |
Adds a filter to the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- filterElementId ElementId
- ElementId of the filter.

Exception | Condition |
---|---|
ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is already applied to the view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |

The filter will be added with default overrides, which means that there will be no change in the view's display. The filter is appended as the last filter in the order of filters applied to this view.