Checks that if there is a solid-solid cut between two elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- first
- Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid.
- second
- Type: Autodesk.Revit.DB Element
The solid being cut or the cutting solid.
- firstCutsSecond
- Type: System Boolean %
If the return value of this function is true, this indicates which element is the cutting element from the pair. True if the first solid cuts the second one, false if the second solid cuts the first one.
Return Value
True if there is a solid-solid cut between the input elements, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |