CutExistsBetweenElements Method


Solid Solid Cut Utils Cut Exists Between Elements Method

Checks that if there is a solid-solid cut between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CutExistsBetweenElements(
	Element first,
	Element second,
	out bool firstCutsSecond
)

Parameters

first Element
The solid being cut or the cutting solid.
second Element
The solid being cut or the cutting solid.
firstCutsSecond Boolean
If the return value of this function is true, this indicates which element is the cutting element from the pair. True if the first solid cuts the second one, false if the second solid cuts the first one.

Return Value

Boolean
True if there is a solid-solid cut between the input elements, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also