Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.'
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetIndex
- Type: System Int32
The index of the target. Should be between 0 and NumberOfTargets().
Return Value
Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | targetIndex is out of range. |
Autodesk.Revit.Exceptions InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover.' |