Rebar |
Returns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover'.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public RebarConstraintTargetHostFaceType GetRebarConstraintTargetHostFaceType(
int targetIndex
)
Parameters
- targetIndex Int32
- The index of the target. Should be between 0 and NumberOfTargets().
Return Value
RebarConstraintTargetHostFaceTypeReturns the RebarConstraintTargetHostFaceType of the host Element face to which the RebarConstraint is attached.

Exception | Condition |
---|---|
ArgumentException | targetIndex is out of range. |
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'. |