SetAssociatedLevel Method


Sets the Associated Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023

Syntax

C#
public void SetAssociatedLevel(
	ElementId levelId
)
Visual Basic
Public Sub SetAssociatedLevel ( _
	levelId As ElementId _
)
Visual C++
public:
void SetAssociatedLevel(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB ElementId
The id of the Level.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException this operation failed.

See Also