SetAssociatedLevel Method


Sets the Associated Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public void SetAssociatedLevel(
	ElementId levelId
)
Visual Basic
Public Sub SetAssociatedLevel ( _
	levelId As ElementId _
)
Visual C++
public:
void SetAssociatedLevel(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The id of the Level.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException this operation failed.

See Also