SetViewsAndSheets Method


Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public void SetViewsAndSheets(
	IList<ElementId> viewsAndSheets
)
Visual Basic
Public Sub SetViewsAndSheets ( _
	viewsAndSheets As IList(Of ElementId) _
)
Visual C++
public:
void SetViewsAndSheets(
	IList<ElementId^>^ viewsAndSheets
)

Parameters

viewsAndSheets
Type: System.Collections.Generic IList ElementId
The ids of the views and sheets.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also