AddReferencePoint Method (XYZ)


Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void AddReferencePoint(
	XYZ refPoint
)
Visual Basic
Public Sub AddReferencePoint ( _
	refPoint As XYZ _
)
Visual C++
public:
void AddReferencePoint(
	XYZ^ refPoint
)

Parameters

refPoint
Type: Autodesk.Revit.DB XYZ
The coordinates of the new reference point.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also