AddReferencePoint Method (XYZ)


Direct Shape Type Add Reference Point(XYZ) Method

Adds a reference point to the DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddReferencePoint(
	XYZ refPoint
)

Parameters

refPoint XYZ
The coordinates of the new reference point.
Exceptions
Exception Condition
ArgumentException The input point lies outside of Revit design limits.
ArgumentNullException A non-optional argument was null
See Also