CylindricalHelix Class


A cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public class CylindricalHelix : Curve
Visual Basic
Public Class CylindricalHelix _
	Inherits Curve
Visual C++
public ref class CylindricalHelix : public Curve

Remarks

The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.

Inheritance Hierarchy

See Also