CylindricalHelix Class


Cylindrical Helix Class

A cylindrical helix.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CylindricalHelix : Curve

The CylindricalHelix type exposes the following members.

Properties
Name Description
Public property BasePoint The base point of the axis of the cylindrical helix.
Public property Height Height of the cylindrical helix.
Public property IsRightHanded True if the helix is right handed, false if the helix is left handed.
Public property Pitch The pitch of the cylindrical helix.
Public property Radius The radius of the cylindrical helix.
Public property XVector The X direction vector.
Public property YVector The Y direction vector.
Public property ZVector The Z direction vector, which is same as the axis direction vector.
Top
Methods
Name Description
Public method Static member Create Create a cylindrical helix.
Top
Remarks
The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.
See Also