CylindricalHelix Class


Cylindrical Helix Class

A cylindrical helix.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class CylindricalHelix : Curve

The CylindricalHelix type exposes the following members.

Properties
Name Description
Public property ApproximateLength The approximate length of the curve.
(Inherited from Curve )
Public property BasePoint The base point of the axis of the cylindrical helix.
Public property GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Height Height of the cylindrical helix.
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsBound Describes whether the parameter of the curve is restricted to a particular interval.
(Inherited from Curve )
Public property IsClosed Describes whether the curve is closed.
(Inherited from Curve )
Public property IsCyclic The boolean value that indicates whether this curve is cyclic.
(Inherited from Curve )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property IsRightHanded True if the helix is right handed, false if the helix is left handed.
Public property Length The exact length of the curve.
(Inherited from Curve )
Public property Period The period of this curve.
(Inherited from Curve )
Public property Pitch The pitch of the cylindrical helix.
Public property Radius The radius of the cylindrical helix.
Public property Reference Returns a stable reference to the curve.
(Inherited from Curve )
Public property Visibility The visibility.
(Inherited from GeometryObject )
Public property XVector The X direction vector.
Public property YVector The Y direction vector.
Public property ZVector The Z direction vector, which is same as the axis direction vector.
Top
Methods
Name Description
Public method Clone Returns a copy of this curve.
(Inherited from Curve )
Public method ComputeClosestPoints
(Inherited from Curve )
Public method ComputeDerivatives Returns the vectors describing the curve at the specified parameter.
(Inherited from Curve )
Public method ComputeNormalizedParameter Computes the normalized curve parameter from the raw parameter.
(Inherited from Curve )
Public method ComputeRawParameter Computes the raw parameter from the normalized parameter.
(Inherited from Curve )
Public method Static member Create Create a cylindrical helix.
Public method CreateOffset Creates a new curve that is an offset of the existing curve.
(Inherited from Curve )
Public method CreateReversed Creates a new curve with the opposite orientation of the existing curve.
(Inherited from Curve )
Public method CreateTransformed Crates a new instance of a curve as a transformation of this curve.
(Inherited from Curve )
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Distance Returns the shortest distance from the specified point to this curve.
(Inherited from Curve )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method Evaluate Evaluates and returns the point that matches a parameter along the curve.
(Inherited from Curve )
Public method GetEndParameter Returns the raw parameter value at the start or end of this curve.
(Inherited from Curve )
Public method GetEndPoint Returns the 3D point at the start or end of this curve.
(Inherited from Curve )
Public method GetEndPointReference Returns a stable reference to the start point or the end point of the curve.
(Inherited from Curve )
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Intersect(Curve) Obsolete.
Calculates the intersection of this curve with the specified curve.
(Inherited from Curve )
Public method Intersect(Curve, CurveIntersectResultOption) Calculates the intersection of this curve with the specified curve.
(Inherited from Curve )
Public method Intersect(Curve, IntersectionResultArray ) Obsolete.
Calculates the intersection of this curve with the specified curve and returns the intersection results.
(Inherited from Curve )
Public method IsInside(Double) Indicates whether the specified parameter value is within this curve's bounds.
(Inherited from Curve )
Public method IsInside(Double, Int32 ) Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
(Inherited from Curve )
Public method MakeBound Changes the bounds of this curve to the specified values.
(Inherited from Curve )
Public method MakeUnbound Makes this curve unbound.
(Inherited from Curve )
Public method Project Projects the specified point on this curve.
(Inherited from Curve )
Public method SetGraphicsStyleId Sets the graphics style id for this curve.
(Inherited from Curve )
Public method Tessellate Valid only if the curve is bound. Returns a polyline approximation to the curve.
(Inherited from Curve )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.
See Also