Reference Constructor


Creates a Reference with the supplied element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public Reference(
	Element element
)
Visual Basic
Public Sub New ( _
	element As Element _
)
Visual C++
public:
Reference(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB Element
The element to create a reference.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the parameter is a null reference ( Nothing in Visual Basic) .

See Also