Reference Constructor


Creates a Reference with the supplied element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public Reference(
	Element element
)
Visual Basic
Public Sub New ( _
	element As Element _
)
Visual C++
public:
Reference(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DBElement
The element to create a reference.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the parameter is a null reference (Nothing in Visual Basic).

See Also