Sets the handles representing the cardinal directions in 3D.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- positive
- Type: SystemBoolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
- xDir
- Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The X direction handle.
- yDir
- Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The Y direction handle.
- zDir
- Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The Z direction handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |