Exporter |
Sets the handles representing the cardinal directions in 3D.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static void SetGlobal3DDirectionHandles(
bool positive,
IFCAnyHandle xDir,
IFCAnyHandle yDir,
IFCAnyHandle zDir
)
Parameters
- positive Boolean
- True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
- xDir IFCAnyHandle
- The X direction handle.
- yDir IFCAnyHandle
- The Y direction handle.
- zDir IFCAnyHandle
- The Z direction handle.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |