SetLocalPlacement Method


Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetLocalPlacement(
	IFCAnyHandle localPlacement
)
Visual Basic
Public Sub SetLocalPlacement ( _
	localPlacement As IFCAnyHandle _
)
Visual C++
public:
void SetLocalPlacement(
	IFCAnyHandle^ localPlacement
)

Parameters

localPlacement
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The IfcLocalPlacement handle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also