Defines the basis of the old coordinate system in the new coordinate system.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idx
- Type: SystemInt32
The index of the basis vector: 0, 1 or 2.
Remarks
This corresponds to the first three column vectors of the conventional 3x4 matrix representation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the transform is internally marked as read-only. |