Transform Basis Property |
Defines the basis of the old coordinate system in the new coordinate system.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter. |
InvalidOperationException | Thrown when the transform is internally marked as read-only. |

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.