FabricationPartSizeMap Constructor (String, Double, Double, Boolean, ConnectorProfileType, Int32, Int32)


Creates a new instance of the FabricationPartSizeMap class.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public FabricationPartSizeMap(
	string size,
	double widthDiameter,
	double depth,
	bool isProductList,
	ConnectorProfileType profileType,
	int serviceId,
	int paletteId
)
Visual Basic
Public Sub New ( _
	size As String, _
	widthDiameter As Double, _
	depth As Double, _
	isProductList As Boolean, _
	profileType As ConnectorProfileType, _
	serviceId As Integer, _
	paletteId As Integer _
)
Visual C++
public:
FabricationPartSizeMap(
	String^ size, 
	double widthDiameter, 
	double depth, 
	bool isProductList, 
	ConnectorProfileType profileType, 
	int serviceId, 
	int paletteId
)

Parameters

size
Type: SystemString
The size display string for the straight that can be used by the user interface.
widthDiameter
Type: SystemDouble
The width or diameter of the straight.
depth
Type: SystemDouble
The depth of the straight.
isProductList
Type: SystemBoolean
Set if the straight a product list or not.
profileType
Type: Autodesk.Revit.DBConnectorProfileType
Set the shape of the straight.
serviceId
Type: SystemInt32
Set the service identifier of the straight.
paletteId
Type: SystemInt32
Set the palette identifier of the straight.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also