Fabrication |
Creates a new instance of the FabricationPartSizeMap class.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FabricationPartSizeMap(
string size,
double widthDiameter,
double depth,
bool isProductList,
ConnectorProfileType profileType,
int serviceId,
int paletteId
)
Parameters
- size String
- The size display string for the straight that can be used by the user interface.
- widthDiameter Double
- The width or diameter of the straight.
- depth Double
- The depth of the straight.
- isProductList Boolean
- Set if the straight a product list or not.
- profileType ConnectorProfileType
- Set the shape of the straight.
- serviceId Int32
- Set the service identifier of the straight.
- paletteId Int32
- Set the palette identifier of the straight.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |