ChangePanelType Method


Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Element ChangePanelType(
	Element panel,
	ElementType newSymbol
)
Visual Basic
Public Function ChangePanelType ( _
	panel As Element, _
	newSymbol As ElementType _
) As Element
Visual C++
public:
Element^ ChangePanelType(
	Element^ panel, 
	ElementType^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit.DBElement
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit.DBElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown if the input symbol can't be used for the panel.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the type change failed.

See Also