ChangePanelType Method


Curtain Grid Change Panel Type Method

Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Element ChangePanelType(
	Element panel,
	ElementType newSymbol
)

Parameters

panel Element
The panel to be changed, it can be a type of Panel or Wall .
newSymbol ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

Element
If operation succeeds, the modified panel element is returned.
Exceptions
Exception Condition
ArgumentException Thrown if the input symbol can't be used for the panel.
InvalidOperationException Thrown when the type change failed.
See Also