CanConnectLevel Method


Checks if the given level can be connected into multistory stairs. You cannot connect levels between standard stairs top and bottom or already connected.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public bool CanConnectLevel(
	ElementId levelId
)
Visual Basic
Public Function CanConnectLevel ( _
	levelId As ElementId _
) As Boolean
Visual C++
public:
bool CanConnectLevel(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The id of the level.

Return Value

True if the level can be connected to this multistory stairs, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also