CanConnectLevel Method


Multistory Stairs Can Connect Level Method

Checks if the given level can be connected into multistory stairs. You cannot connect levels between standard stairs top and bottom or already connected.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanConnectLevel(
	ElementId levelId
)

Parameters

levelId ElementId
The id of the level.

Return Value

Boolean
True if the level can be connected to this multistory stairs, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also