Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- group
- Type: SystemString
The fabrication connector group.
- name
- Type: SystemString
The fabrication connector name.
- domain
- Type: Autodesk.Revit.DBConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DBConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.
Return Value
Return the fabrication connector identifier. Returns -1 if not found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |