Fabrication |
Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public int LocateFabricationConnector(
string group,
string name,
ConnectorDomainType domain,
ConnectorProfileType shape
)
Parameters
- group String
- The fabrication connector group.
- name String
- The fabrication connector name.
- domain ConnectorDomainType
- ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
- shape ConnectorProfileType
- ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.
Return Value
Int32Return the fabrication connector identifier. Returns -1 if not found.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |