Indicates if the element can be cut by an instance with unattached voids.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DBElement
The element to be cut
Return Value
Returns true if the element can be cut by an instance with unattached voids.Remarks
Elements in a project can be cut if they are host elements or family instances with a category Generic Model or one of the structural categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |