Add Method


Adds a copy of the input ExternallyTaggedNonBRep to this collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public void Add(
	ExternallyTaggedNonBRep geometry
)
Visual Basic
Public Sub Add ( _
	geometry As ExternallyTaggedNonBRep _
)
Visual C++
public:
void Add(
	ExternallyTaggedNonBRep^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DBExternallyTaggedNonBRep
The ExternallyTaggedNonBRep to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ExternalGeometryId of geometry already exists in this collection.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also