Creates a new stairs path for the stairs in a multistory stairs with the specified stairs path type only in the plan view.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- multistoryStairsId
- Type: Autodesk.Revit.DBLinkElementId
The id of the multistory stairs element either in the host document or in a linked document.
- typeId
- Type: Autodesk.Revit.DBElementId
The type of stairs path.
Return Value
The new stairs paths.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Cannot add more stairs paths on multistoryStairsId. -or- The typeId is not a valid stairs path type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |