CreateOnMultistoryStairs Method


Stairs Path Create On Multistory Stairs Method

Creates a new stairs path for the stairs in a multistory stairs with the specified stairs path type only in the plan view.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<StairsPath> CreateOnMultistoryStairs(
	Document document,
	LinkElementId multistoryStairsId,
	ElementId typeId
)

Parameters

document Document
The document.
multistoryStairsId LinkElementId
The id of the multistory stairs element either in the host document or in a linked document.
typeId ElementId
The type of stairs path.

Return Value

IList StairsPath
The new stairs paths.
Exceptions
Exception Condition
ArgumentException Cannot add more stairs paths on multistoryStairsId. -or- The typeId is not a valid stairs path type.
ArgumentNullException A non-optional argument was null
See Also