TriangulationInterfaceForTriangulatedShellComponent Constructor


Constructs an interface object for a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public TriangulationInterfaceForTriangulatedShellComponent(
	TriangulatedShellComponent externalTriangulatedShellComponent
)
Visual Basic
Public Sub New ( _
	externalTriangulatedShellComponent As TriangulatedShellComponent _
)
Visual C++
public:
TriangulationInterfaceForTriangulatedShellComponent(
	TriangulatedShellComponent^ externalTriangulatedShellComponent
)

Parameters

externalTriangulatedShellComponent
Type: Autodesk.Revit.DBTriangulatedShellComponent
The TriangulatedShellComponent that the interface object represents.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also