Create Method (Document, IList(Curve), Level, XYZ, Boolean)


Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static BeamSystem Create(
	Document document,
	IList<Curve> profile,
	Level level,
	XYZ direction,
	bool is3d
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	profile As IList(Of Curve), _
	level As Level, _
	direction As XYZ, _
	is3d As Boolean _
) As BeamSystem
Visual C++
public:
static BeamSystem^ Create(
	Document^ document, 
	IList<Curve^>^ profile, 
	Level^ level, 
	XYZ^ direction, 
	bool is3d
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which the new BeamSystem is created.
profile
Type: System.Collections.GenericIListCurve
The profile of the BeamSystem.
level
Type: Autodesk.Revit.DBLevel
The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
direction
Type: Autodesk.Revit.DBXYZ
The direction is the direction of the BeamSystem.
is3d
Type: SystemBoolean
Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.

Return Value

If successful, a new BeamSystem object will be returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input profile contains at least one helical curve and is not supported for this operation. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also