Beam |
Creates a new BeamSystem with specified profile curves.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static BeamSystem Create(
Document document,
IList<Curve> profile,
Level level,
XYZ direction,
bool is3d
)
Parameters
- document Document
- The document in which the new BeamSystem is created.
- profile IList Curve
- The profile of the BeamSystem.
- level Level
- The level on which the BeamSystem is to be created. The work-plane of the BeamSystem will be the sketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
- direction XYZ
- The direction is the direction of the BeamSystem.
- is3d Boolean
- Whether the BeamSystem is 3D. If the BeamSystem is 3D, the sketchPlane must be a level, otherwise an exception will be thrown.
Return Value
BeamSystemIf successful, a new BeamSystem object will be returned.

Exception | Condition |
---|---|
ArgumentException | The input profile contains at least one helical curve and is not supported for this operation. -or- The input level does not have associated plan view. -or- The plan view associated with the input level is not valid. -or- Can not get valid sketch plane from the input level. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |