IsPermittedSurfaceType Method


A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static bool IsPermittedSurfaceType(
	Surface surface
)
Visual Basic
Public Shared Function IsPermittedSurfaceType ( _
	surface As Surface _
) As Boolean
Visual C++
public:
static bool IsPermittedSurfaceType(
	Surface^ surface
)

Parameters

surface
Type: Autodesk.Revit.DBSurface
Surface object intended to be used as a face surface.

Return Value

True if surface of this type may be used as a face surface, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also