BRep |
A validator function that checks whether the surface object is of type supported as face surface by BRepBuilder.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- surface Surface
- Surface object intended to be used as a face surface.
Return Value
BooleanTrue if a surface of this type may be used as a face surface, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The allowed surface types are ConicalSurface, CylindricalSurface, Plane, RevolvedSurface, RuledSurface, and HermiteSurface.